Reading error codes on an early 3200GT

davy83

Member
Messages
2,351
Are the Fiat based Airbag and ABS files still available? I would like to try this, i have a 2001 KWP 2000 protocol car with a std connector.
 

galaeco

New Member
Messages
7
Thank very much for the quick support. Really appreciated!
I already installed Windows XP (32bit) on my laptop but I don't have access to the car yet, as it is sleeping in my friend's garage.
I will try this tomorrow morning in the car and give you some feedback.

Regarding cable drivers, I tried to install the FTDI driver first (the appropriate version, for windows XP 32bit - CDM 2.08.24 WHQL Certified) but only the CH340 drivers that came with the cable would install, so, not FTDI.

For the sake of curiosity, I opened Unidiag at home for a quick look and no COM port appears on the dropdown menu. The cable does appear in the Device Manager as COM1, but Unidiag won't see it. So tomorrow we'll see if:
  1. I have to first connect the VAG KKL cable to the ISO connector in the car with ignition ON, followed by connecting the USB to the PC, or;
  2. I will have to purchase an FTDI cable somewhere to make this work.
Fingers crossed :)
 
Last edited:

galaeco

New Member
Messages
7
Hello all, got some updates and some questions.
I will follow a topic-wise (and chronological) description of my approach.

As I said earlier, the car is a 2000' Quattroporte IV Evoluzione (3200cc V8 twin turbo engine) which I believe shares the engine and ECU with the 3200GT model.
Well, let's start from the beginning:



1. The cable
--> I initially purchased a random VAG KKL cable from an online store and borrowed the famous 3-pin ISO to OBD converter from a friend. When it arrived I noticed that it had the CH340 chipset (TTL to USB transceiver chip). The CD that came inside the package had both the CH340 and the FTDI drivers but only the CH340 would install (tried both). Proceeded with the setup of the COM port with the expected settings. Some expected settings, like latency and usb transfer sizes, were obviously missing in the CH340 driver. So I set it up as COM1, 9600 bits per second, etc.. (the usual).
Opening UniDiagKWP2000_0_5_0_11, no COM port would appear in the combobox. When Sander wrote the software he specifically used the FTDI D2XX drivers. So it makes sense.

--> I went shopping online again, this time for a FTDI cable. Bought this one: https://www.amazon.es/OTKEFDI-diagnóstico-Interruptor-Herramienta-automóviles/dp/B07K75L4QG/ref=sr_1_14?__mk_es_ES=ÅMÅŽÕÑ&crid=17KTLTHH1O0ZJ&dchild=1&keywords=vag+kkl&qid=1605573378&sprefix=VAG+KKL,aps,185&sr=8-14 . This time, the FTDI drivers did install correctly. I used the genuine drivers from the FTDI website. This time I was able to configure the COM port appropriately: COM 1, 9600 bps, 8N1, no flow control, 256-byte receive and transmit buffers, 1 millisecond latency timer.



2. The laptop

--> I used my 2010 MacBook Pro : 2,66 GHz Intel Core 2 Duo, 4Gb RAM. I installed Windows using Bootcamp, so the OS runs natively, not under any type of virtualisation.

--> Installed Windows XP Professional (SP3).

--> Opening UniDiagKWP2000_0_5_0_11, the combobox showed an hex identifier for the COM port, instead of 'COM1' (as seen with another user of this forum in a previous page of this thread). A different USB port would show a different hex identifier, but the same USB port would always show the same hex identifier. Clicking on "Start + ID" wouldn't connect. The button would go gray/disabled for a couple of seconds, returning to the enable state. So, no connection. Tried the "Start Comm 2000" and also reading the ECU info. No success in any attempt.

--> Opening UniDiagKWP2000_0_4_0_3 and UniDiagKWP2000_0_3_3_1 would show a preloaded list of COM ports in the combobox. Same behaviour as with UniDiagKWP2000_0_5_0_11.

--> Tried 2 different versions of the genuine FTDI drivers: first I tried the most recent version, then an older version from 2005. Before installing new drivers I uninstalled the previously installed drivers + ran the FTClean utility from FTDI to make sure everything was clean from the file system and system registry. This was to make sure I had a 'really' clean install, each time. Same behaviour. No connection.

--> Removed Windows XP and installed Windows 7 Ultimate. Dowloaded Win7 versions of the FTDI drivers.

--> Tried UniDiagKWP2000_0_3_3_1, UniDiagKWP2000_0_4_0_3. Same behaviour. A preloaded list in the combobox. No connection to the ECU.

--> Tried UniDiagKWP2000_0_5_0_11: an hex identifier (0x00000034) as COM port. No connection.



3. ELM 327

--> Decided to make an appeal to the Gods and tried a Bluetooth dongle (ELM 327). The manufacturer stated that it supports ISO 14230-4 (i.e., KWP2000) with both fast init and slow init (5 baud init, 10.4kbaud data). Didn't work with both Torque Pro and EOBD Facile.



4. Manual debugging

--> Pulled my sleeves up to elbows and got myself a multimeter. Question: what if the KKL cable isn't getting any electrical connection at all?

--> Unplugged the VAG KKL cable and checked the electrical properties of the ISO<-->OBD converter.
Pin 5 (chassis/signal ground): 0V + continuity to ground was checked;
Pin 16 (battery power): +12,3V
Pin 7 (k-line): ~12V (Rationale: 12V is a logical 'zero' meaning k-line is 'awake', 0V is a logical 'one'). so.... Houston, we have have K-line!



5. What next?

--> Still haven't dropped the towel to the floor. Things I want to check:
----> dig deeper in the footwell to check which ECU is actually in the car (is it the IAW4CM as I believe, or something different?)
----> is there any other grey ISO connector? The one I am using is the one located in the passenger footwell. This car is a LHD so the ISO connector is on the front right footwell (as expected, matching the pedal location of the English RHD model versions). It is a grey 3-pin ISO connector, with yellow insulating rubber and a red connector core.

Question: has any of you found similar behaviour? has any of you ever found a second grey connector somewhere in the car? does any of you have any extra suggestion?

Cheers!

77708
 
Last edited:

redsonnylee

Centenary Club
Messages
1,345
Sorry to hear about your troubles, I'm not familar with QP IV so can't say if the grey cable in your photo is the correct one. I do remember in my 3200 there was a second connector but cant remeber what that one was for.
For comparrison I use an HP Mini, Windows XP Professional version 2002, Service pack 3, 1.20ghz,1.75bg ram so less powerful than yours so I don't see a problem there.
It took me a while to get the connection going as you have to be very careful to follow the instructions, if you miss one step you have to start over.