Couple of problems have emerged.

jasst

Member
Messages
1,790
Trip to air con specialist today, plenty of refrigerant, but compressor is not engaging, He thinks its electrical, fuse ok, relay ok, might be pressure switch, so he is going to have it in to have a look at, still safe to drive as it is not engaging, but bloody hot on a day like today.
 

montravia

Member
Messages
1,245
Sympathise.

Discovered mine hasn't been working. Finally conclusive today. We forget what cars were like without a/c. Quite unpleasant.

Shame new unit fitted 1,400 miles ago in an attempt to overcome a failed clutch.
This one hasn't been engaging either which makes me suspicious that it's a false sensor rather than clutch. We'll sweaty see.

Ah well windows down all the way to and from Coventry Airport along the Fosse Way brought some sonic recompense.
Blessed machine.
Flight scrubbed too. Gusting x- wind 80 degrees to rwy, beyond GA aircraft x-wind limits.
And after last flight's observation from pilot on finals behind me watching me struggle on approach resulting in 'All stations. Warning alert, severe windshear on final approach' decided had enough challenges for this week.
'Better being down here wishing you were up there rather than up there wishing you were down here'.

Shame on both instances on an otherwise glorious day.
 

jasst

Member
Messages
1,790
All is now well! On return home from Sports Italia also discovered cooling fans not working and no air con and any code reader unable to communicate with Engine ECU, Was fearing worst re ECU, and could not find anybody who was prepared to have a look at it, so decided to start at the beginning, lets check all fuses, and lo and behold found fuse that controls Lambda's blown, replaced and suddenly fans work, air con works and code reader can communicate with ECU, so all reset, and just passed MOT with no written advisory's, so we can breath a huge sigh of relief! :anime:Oh, and I actually managed to do 2764 miles last year! all of which were blasts over Exmoor/Dartmoor.
 
Last edited:

philw696

Moderator
Staff member
Messages
16,128
It's always best to check the basics first.
Nice that she is back to normal :)
 

conaero

Forum Owner
Messages
31,988
All is now well! On return home from Sports Italia also discovered cooling fans not working and no air con and any code reader unable to communicate with Engine ECU, Was fearing worst re ECU, and could not find anybody who was prepared to have a look at it, so decided to start at the beginning, lets check all fuses, and lo and behold found fuse that controls Lambda's blown, replaced and suddenly fans work, air con works and code reader can communicate with ECU, so all reset, and just passed MOT with no written advisory's, so we can breath a huge sigh of relief! :anime:Oh, and I actually managed to do 2764 miles last year! all of which were blasts over Exmoor/Dartmoor.
Excellent, well done.

It probably blew that lot when you dragged your lambda plug across the tarmac :)
 
Last edited:

Felonious Crud

Moderator
Staff member
Messages
16,615
So, very ineffective / non existent air con, but ran ok for 15 miles, no sign of belt slippage or burning smells? Next stop air con specialist to get it tested/ recharged, so that's 2 out of 3 cars with no air con!
Two out of three ain't bad.
 

Wack61

Member
Messages
6,791
So, very ineffective / non existent air con, but ran ok for 15 miles, no sign of belt slippage or burning smells? Next stop air con specialist to get it tested/ recharged, so that's 2 out of 3 cars with no air con!
There's an ATS Groupon for AC £36 I think