Engine Advice

Pixel

New Member
Messages
25
Hi all,

I took my 2009 Granturismo S 4.7 out for a spin today and gave it the beans. When I got back home I noticed the engine sounded really rough and shuddering. Almost like it wasn't running on all cylinders. I could feel it straight away though the car. I left it 5-10min and started her up again, everything seems smooth normal again.
I've plugged in my ECU reader and run the diagnose feature - it checked the spark on the plugs which stated 'passed' on all but showed 'fail' on the VVT Monitor. Could this be the problem? My initial thoughts were that the plugs need changing but Im just not sure.

The car is regularly serviced on-time and the next one is due late September.

Images attached
 

Attachments

Silvercat

Member
Messages
828
It will be an ignitor coil which has failed.
Exactly the same happened to my old 2009 QP4.7S. My diagnostic computer identified the misfiring cylinder, so bought a new ignitor coil for £105. 40 minutes later new ignitor coil fitted and engine purring like a tiger again. Very simple to change.
Note: I was advised by the Maserati Inde that if one ignitor coil fails then it's likely the rest will start to fail shortly to. So best to always keep a spare just in case. My coil failed at 46k miles.
 

Pixel

New Member
Messages
25
It will be an ignitor coil which has failed.
Exactly the same happened to my old 2009 QP4.7S. My diagnostic computer identified the misfiring cylinder, so bought a new ignitor coil for £105. 40 minutes later new ignitor coil fitted and engine purring like a tiger again. Very simple to change.
Note: I was advised by the Maserati Inde that if one ignitor coil fails then it's likely the rest will start to fail shortly to. So best to always keep a spare just in case. My coil failed at 46k miles.
Would this resolve the VVT issue ref the 'fails' the ECU reader picked up? Is there a method to test the ignition coils myself?

Thanks
 

CatmanV2

Member
Messages
34,442
I don't think this is coils, personally, that usually gives a clear misfire on a specific cylinder and a CEL.

I wonder if this is variators going?

C
 

CatmanV2

Member
Messages
34,442
Is there a way I can test the plugs and coils manually? Little project for this weekend
Not that I know of. Normally you'd get a CEL telling you which cylinder was misfiring, then you could move plugs / coils to confirm which is was.

C
 

Oneball

Member
Messages
3,518
You can check the resistance of the coils. Its not always definitive though.

Have a google. And you should be able to find the specs for yours.
 

Pixel

New Member
Messages
25
Theres been a development. Today I was out in the car again all fine but as soon as I got back and put the car into reverse the engine started sound rough and shuddering again. Plugged in the reader again and now have a Pending error code - P1013 (photo attached). No lights on the dash though
 

Attachments

CatmanV2

Member
Messages
34,442
Generic code meaning possibly many things (including an issue with the valve timing on the intake, apparently). At least that's what Google tells me (see what I did there? ;) )

I think you're gonna need a proper diagnostic on this...

C
 

Pixel

New Member
Messages
25
Generic code meaning possibly many things (including an issue with the valve timing on the intake, apparently). At least that's what Google tells me (see what I did there? ;) )

I think you're gonna need a proper diagnostic on this...

C
I checked google first but it was very broad and mixed. Asking on the forums was my next option. Going to speak to Mario @ Autoshield tomorrow :)
 

ensignia

New Member
Messages
15
Is it not normal to vibrate a little at idle?

My 4.7 GTS doesn't shudder or run rough but there is a clear vibration in the interior at idle. The RPM moves ever so slightly up and down but it was never the smoothest or most refined engine in the world.