Granturismo 2013 Side light issue

karldarren

New Member
Messages
18
Hi All
Has anybody on here had any luck with replacing the 501 bulbs on a GT
I’ve replaced mine for good quality LED bulbs.
The issue I now have is that the onboard display is telling me to check the bulbs.
I have read that changing to LEDs can cause this problem so I’m looking for advice with how to rectify the problem.
Thank you in advance.
 

CatmanV2

Member
Messages
48,763
Hi All
Has anybody on here had any luck with replacing the 501 bulbs on a GT
I’ve replaced mine for good quality LED bulbs.
The issue I now have is that the onboard display is telling me to check the bulbs.
I have read that changing to LEDs can cause this problem so I’m looking for advice with how to rectify the problem.
Thank you in advance.

Did you specify CANBUS compatible bulbs? Someone might come along with a specific link, but unless you have those (or add a resistor), it's going to be an issue.

C
 

Gazcw

Member
Messages
7,763
Hi All
Has anybody on here had any luck with replacing the 501 bulbs on a GT
I’ve replaced mine for good quality LED bulbs.
The issue I now have is that the onboard display is telling me to check the bulbs.
I have read that changing to LEDs can cause this problem so I’m looking for advice with how to rectify the problem.
Thank you in advance.
Get a bulb that has the resistor built in to fool the monitor. No guarantee it will work it is very dependant on the bulb selected. I have led reverse lights to provide better lighting out back when you need it. They are probably not monitored,!but never had a problem with those.
 

Troll

Member
Messages
69
I bought CANBUS LED bulbs last week, I installed them in the sidelights when I had the headlights out, but I also had the "check sidelight" errors so I put the standard 501's back in.
 

Gazcw

Member
Messages
7,763
I bought CANBUS LED bulbs last week, I installed them in the sidelights when I had the headlights out, but I also had the "check sidelight" errors so I put the standard 501's back in.
I did the same with led side repeaters and added resistors on the qp. I got the same faults and went back to 501's
 

Zep

Moderator
Messages
9,257
There is a difference between LEDs that don’t trigger the BCM into thinking there is a fault (they have high resistance) and Canbus compatible bulbs (they feature a capacitor). The canbus bulbs work with a PWM signal.

The GT needs the former rather than the latter.