gauge cluster not illuminating when headlight are on

AnvilGransport

New Member
Messages
4
Hello,
I have a 2006 Gransport. The gauge cluster doesn't illuminate when the headlight switch is activated. It came on once, and I'm speaking about the overall white light that lights up the entire cluster for night driving. When it did light up I attempted to see if the rheostat dial adjuster would dim or brighten the light and it did not adjust the illumination brightness at all. The light only came on full strength. Once the head light switch was turn off and back on the gauge cluster would not illuminate. I replaced all the fuses in the pass side floor pan with new micro fuses. I want to get some input prior to pulling the dash apart to replace the rheostat.
 

Zep

Moderator
Messages
3,483
In my memory, this hasn’t been seen before. It sounds like you might well be on the right track with the dimmer, but as I recall (and hopefully someone with a GS can confirm) this also dimmed the lights in the clock and heater controls. Do those lights dim when you operate the dimmer (rheostat)?
 

davy83

Member
Messages
2,165
yes the dimmer control is often flakey, have you tried just turning it back and forward a few times see of the lights come on while you are doing this?
 

Oneball

Member
Messages
1,821
In my memory, this hasn’t been seen before. It sounds like you might well be on the right track with the dimmer, but as I recall (and hopefully someone with a GS can confirm) this also dimmed the lights in the clock and heater controls. Do those lights dim when you operate the dimmer (rheostat)?
From memory on the 3200 it dimmed everything except the daft little LED on the ashtray.

You may have lost one of the tracks on the printed foil on the cluster or it’s come unplugged. Whether it’s that or the dimmer it’s still a cluster out job.
 
Reactions: Zep

AnvilGransport

New Member
Messages
4
so the clock light up. it is only the overall white light that light up the gauge cluster. You can even tell the shift gear indicator dims when you tun on the headlights. the only other set of light that do not illuminate is the AC/heat controls. But please not the one time the white back light did work everything lite up so I know all the bulb worked for that one time it work.
 

AnvilGransport

New Member
Messages
4
the rheostat has the dimmer arm that comes through the gauge cluster. it turn left to right. in effect the overall white light that allows you to see the gauge cluster at night is not working and some one said the rheostat controls that white light.
 

AnvilGransport

New Member
Messages
4
In my memory, this hasn’t been seen before. It sounds like you might well be on the right track with the dimmer, but as I recall (and hopefully someone with a GS can confirm) this also dimmed the lights in the clock and heater controls. Do those lights dim when you operate the dimmer (rheostat)?
clock yes it light up fully no dimming and is still lighting up. the heater control only lite up the one time that the gauge cluster backing light work.
 

Gooner

Centenary Club
Messages
106
I had exactly the same problem in the last few days (2002 Spyder).

I don’t know how I fixed it. I gently turned the dimmer backwards and forwards, with no joy (still dark). I left it turned fully anticlockwise, ie bright, turned the car off and went to bed. Next day when I turned the car on it worked perfectly.

Sorry not to be more help.