Passenger footwell filling with water...!

TimR

Member
Messages
1,013
Before you all tell me my matrix has gone bad, it is fresh water...!
Its only just started doing this it seems...
A couple weeks back I couldnt avoid driving some 160 miles in the deluge of water that was the Tuesday downpour moving north up the UK.
I noticed the dampness and looked in the footwell...a bl00dy pond of filthy water...The conditions were horrendous, so I have dried it out with a mixture of towels/heater/silica etc...I have been telling myself that the conditions were freak and it wont happen again...!!
Just washed the car and its wet in the footwell...!
Whats favourite for the culprit, anybody..Blocked drainage channels somewhere perhaps ?
I'm hopeful its from a scuttle channel (?) or summat..I mean. I dont use water under pressure when I wash the car...& nothing from below either.....:conf2:

Grtzzz...!
 

Zep

Moderator
Messages
2,767
Blocked AC drain. It’s an an easy fix and a few guides around.

Or blocked scuttle drains, so wipers off and remove the cowl for a proper clean out.

Oh - and your heater matrix has failed ;)
 

FIFTY

Member
Messages
1,661
Blocked AC drain. It’s an an easy fix and a few guides around.

Or blocked scuttle drains, so wipers off and remove the cowl for a proper clean out.

Oh - and your heater matrix has failed ;)
WHS

When my car did this it turned out to be a full house
 

TimR

Member
Messages
1,013
Thanks for the pointers- been through the lot this morning - turns out it was a blocked drainage channel on the passenger side under the scuttle...!
Im hoping its sorted now anyway !!
 
Last edited: