Ghibli Satnav issues

northmoor

New Member
Messages
1
Have a 2015 Ghibli, UK model. When I first bought the car, the satnav appeared to be stuck in a cycle of constantly loading but never completing to a point at which it was usable. I used this as a point to knock some money off the vehicle from the dealer who didn't want to the hassle of having to sort it. During the drive home from the dealer, hey presto, the satnav suddenly at some point kicked into life (after maybe an hour or more of continuous driving). Ever since then it was fine. Last weekend one of my key fobs was registering that the battery needed replacing, so I had this done. The next day when driving the car, the satnav was back to it's previous games, it says it is loading, but never finishes loading, and after 10 or 20 seconds the screen flashes black and it goes back to the loading screen. I have no idea if this is linked to the new battery in the key fob or not.

I found a free means to update the uConnect system to what I think is the latest version, which I have just done, wondering if that makes any difference, but it does not appear to have made any difference. I have the Garmin update as well, however, I cannot apply this as the satnav does not load and hence you cannot access the necessary menu to run the satnav update.

Does anyone have any idea how to rectify this problem? I have seen the same issue reported on various Maserati forums with no solution seemingly found. Everything else in the uConnect system works perfectly, it is simply that the satnav is stuck in this cycle of failing to load.

Thanks!
 

P R

Member
Messages
1,130
My previous one did something similar. Just seemed to hang on the loading screen.

Mine was under warranty still (just) and the dealer ended up replacing the unit.
 

MaserMike

Member
Messages
90
Have a 2015 Ghibli, UK model. When I first bought the car, the satnav appeared to be stuck in a cycle of constantly loading but never completing to a point at which it was usable. I used this as a point to knock some money off the vehicle from the dealer who didn't want to the hassle of having to sort it. During the drive home from the dealer, hey presto, the satnav suddenly at some point kicked into life (after maybe an hour or more of continuous driving). Ever since then it was fine. Last weekend one of my key fobs was registering that the battery needed replacing, so I had this done. The next day when driving the car, the satnav was back to it's previous games, it says it is loading, but never finishes loading, and after 10 or 20 seconds the screen flashes black and it goes back to the loading screen. I have no idea if this is linked to the new battery in the key fob or not.

I found a free means to update the uConnect system to what I think is the latest version, which I have just done, wondering if that makes any difference, but it does not appear to have made any difference. I have the Garmin update as well, however, I cannot apply this as the satnav does not load and hence you cannot access the necessary menu to run the satnav update.

Does anyone have any idea how to rectify this problem? I have seen the same issue reported on various Maserati forums with no solution seemingly found. Everything else in the uConnect system works perfectly, it is simply that the satnav is stuck in this cycle of failing to load.

Thanks!
Sounds like it’s a faulty unit which will need replacing or needs a factory system update, I had a similar issue with the Levante - only did it the once, black screen and shut it self down for around 10mins. Came back to life after a short while.
 

keith

Member
Messages
493
On my 2016 MY Ghibli (bought new in 2015), I have found a lot of electrical gremlins including infotainment, can be rectified by disconnecting the 12V battery in the boot. It has a quick disconnect lead so no spanners required.
I think I was one of only a handful of owners who specced the WIFI hub option, and prior to my dealer re-wiring it, I would have to perform this 'reset' on most journeys as it would continuously jam!