Alternator part number for 2007 QP5

agrassick

Junior Member
Messages
38
#1
Hoping you can help, I have a whining coming from my alternator and have been trying to find replacement other than eurospares, however I have come across two different part numbers both claiming to fit the car

325296 these tend to be around £600
193120 these tend to be cheaper around £400

Obviously looking to save money but want to make sure it will work and most importantly not cause any electrical damage. Any advice greatly appreciated
 
Messages
1,572
#2
Out of interest how many miles have you done?
My alternator went recently on my 2007 QP Auto having done 60K. Emblem said that they had just replaced another around the same mileage...
Mine came from Eurospares
Eb
 

agrassick

Junior Member
Messages
38
#3
Sounds like it could be to do with the miles just hit 64K. Think I will go for the Eurospares unit might be more expensive but at least you know you're getting the right part.
 

agrassick

Junior Member
Messages
38
#4
Got the whining sorted out on the alternator, I ended up taking it off and getting it refurbished at www.londonessexautoelectrics.co.uk full refers, new bearings and did pack all in £180 looked brand new when completed, a bargain I thought. Was a long job to get out, have to remove the wipers, wiper motor, bulk head, inlet manifold, air filter and drive belt but got it done!
Have to see what the next issue that comes up is :)
 
Messages
520
#5
Got the whining sorted out on the alternator, I ended up taking it off and getting it refurbished at www.londonessexautoelectrics.co.uk full refers, new bearings and did pack all in £180 looked brand new when completed, a bargain I thought. Was a long job to get out, have to remove the wipers, wiper motor, bulk head, inlet manifold, air filter and drive belt but got it done!
Have to see what the next issue that comes up is :)
I just had mine refurbed at the same place.. <£230 delivered ! Looks like new. Replaced rotor ( it was beyond a rewind) new diode pack ( upgraded ) and new bearings. Only gone a couple of days...! ;)
I didn’t see your post originally or would have suggested to give them a call...

They do quite a few apparently , Denso are a good brand. I can only guess the heat from it’s position takes it,s toll...dunno ? :rolleyes:

Result....
 

conaero

Forum Owner
Messages
27,823
#7
Hum, my experience of refurbed altenators is a horror story. The only person I know who had it done was Benny and it failed twice, once nearly setting fire to the car and exploading the battery. I hope yours works for you and if you could come back in a year and let us know all is good, it would be appreciated.

Problems seems to stem from regulation and the diode pack. This was the fault both times, one over charging and one under charging.
 
Messages
27,279
#8
I had mine on the GT fail. It was over voltage. No damage but it locks the ZF into 3rd or 5th depending on which is closer

C