3200GT Acceleration

Messages
968
#1
Quick question for those with a manual 3200, when you are accelerating and change into the next gear does yours fall off boost?

For example in mine when I’m in 2nd gear and accelerating full throttle all the way to max revs (not hitting the limiter) then I change into 3rd there is a delay until it gets back on boost.
 
Messages
4,055
#2
Quick question for those with a manual 3200, when you are accelerating and change into the next gear does yours fall off boost?

For example in mine when I’m in 2nd gear and accelerating full throttle all the way to max revs (not hitting the limiter) then I change into 3rd there is a delay until it gets back on boost.
No, but if your in Sport with the ASR off you have to watch out for wheel spin and the sudden lose of control:cool:

Seriously though, there most be some turbo lag as they will slow down when you lift off the throttle to change gear, not that I've noticed though

Dave
 
Messages
45
#3
Same with Auto tranny, falls of boost on gearchanges and takes a while to get it going again. Annoying but i guess it's a feature on old turbo car? If someone knows a fix i'm interested!
 
Messages
968
#6
Same with Auto tranny, falls of boost on gearchanges and takes a while to get it going again. Annoying but i guess it's a feature on old turbo car? If someone knows a fix i'm interested!
Thanks all

I’m not sure if the manual and auto are comparable due to the gear ratios. Could of course be normal.

If I’m trundling along in 3rd and I come off the throttle and back on again quickly it’ll splutter/cough. The air filters are old, was changing them anyway. Will also check the fuel pressure and see what that’s doing.

What fuel do you guys use?
 
Last edited:
Messages
38
#10
Quick question for those with a manual 3200, when you are accelerating and change into the next gear does yours fall off boost?

For example in mine when I’m in 2nd gear and accelerating full throttle all the way to max revs (not hitting the limiter) then I change into 3rd there is a delay until it gets back on boost.
Mine is auto, I have not noticed any power loss during gear change. I am not mechanically minded at all but when I got her for service I was told that I was loosing a bit of boost due to a valve leak or valve not functioning properly which we replaced. I always use Shell V Power and drive her in Sport mode outside the city and it feels very very quick.
 
Messages
968
#11
Mine is auto, I have not noticed any power loss during gear change. I am not mechanically minded at all but when I got her for service I was told that I was loosing a bit of boost due to a valve leak or valve not functioning properly which we replaced. I always use Shell V Power and drive her in Sport mode outside the city and it feels very very quick.
Mine feels quick too i was just surprised last night with the gap in power on the change from 2nd to 3rd.

Are any of you guys local to Worcester or the Midlands. Might be good if someone else drives it if I can’t find anything?
 
Messages
1,956
#14
I have a 2001 auto and no loss of boost during spirited acceleration with my car, its pulling all the way until your bowels make you slow down. The auto and manual have different torque curves I believe? I think they messed with the ECU on the auto because it has less gears (4 with overdrive) so needs to pull over a wider rev range, this may not be true but I thought I had read that some where. I would not expect there to be a loss on the manual, just because its a Maserati and they may be slack on some things but straight line performance does not seem to be an area where they are sloppy. So some thing sounds not quite right here, but its hard to tell because clearly in this problem there is also your expectations! :)
 

Rex B

Junior Member
Messages
520
#15
No loss of boost on mine, could be pop off valves slow to close after reapplying throttle, but also should not cough or splutter when putting your foot down something not quite right but difficult to diagnose. I always use 98 octane fuel , also worth checking the plugs sometimes the oil sealing rings leak around the plugs on the cam covers causing missing.

Rex B
 
Messages
968
#17
Thanks all. Have to go over to Tenbury in the morning so will take the 3200.

No loss of boost on mine, could be pop off valves slow to close after reapplying throttle, but also should not cough or splutter when putting your foot down something not quite right but difficult to diagnose. I always use 98 octane fuel , also worth checking the plugs sometimes the oil sealing rings leak around the plugs on the cam covers causing missing.

Rex B
Cam covers are ok. It only stutters when you take your foot completely off and put it back down again.
 
Messages
968
#20
No that's not right, mine never stutters what ever you do with the throttle

Hence the two smaller turbos keeping the engine on boost, unlike my brother in laws Sierra Cosworth

Dave
Thanks Dave.

I think the stutter is most noticeable at a little above 2000rpm. Which makes think it’s not turbo related??